If you encounter this issue while searching in your space, open and save the eSign Space Settings. This will register the eSign custom fields for this project, providing that the eSign fields have been added to at least one project in the site manually.
For the first project, follow the steps below to Add the fields manually to that project to enable search and display of the eSign custom fields.
Error
The custom search fields included with eSign for Jira do not appear when searched, and/or claim to not exist when used.
Cause
An Atlassian change to custom fields means they are no longer added to new spaces when they are created via API or app installation.
Things to Check
To add the signature search fields to a space:
-
Go to Space Settings
-
Under Fields press "Add Field" in the top right corner.
-
Select Signature Count, Signature Export, Signature Pending, Signature Status Count, Signatures Finalized, Signed By, and Signed On.
-
Press "Add 7 Fields" to include them in the space.
As long as a user has access to any space with these fields added, they should be operational in all of that user’s other spaces as well.