Problem
eSign Documents is functional immediately on install in all Confluence Spaces within the site. Occasionally users will see a message like ‘Content view/edit access lock rejected by Atlassian API with code 404’ when trying to use eSign Documents within certain spaces.
Cause
eSign uses the Atlassian API to access the Confluence pages, apply page security, store signature metadata and publish documents. eSign has an associated app user “eSign Document Mgmt” that is granted admin access to the spaces to perform these functions on install.
If the space permissions are manually adjusted by an administrator, access for this app user can be removed. This will prevent eSign from being able to work within this specific space.
If page restrictions are applied to a specific page limiting who can edit the page, this can also prevent eSign access.
Resolution - Space Settings
To fix missing space permissions, as a space or site administrator, navigate to the Confluence Space Settings > Space Access > Users area and verify that the eSign Document Mgmt user is listed and has all the permissions as per the screenshot below. If it is not there, add it.
Once permissions are restored to eSign Document Mgmt user, retry the original page.
Resolution - Page Restrictions
To fix local page restrictions, access the Share dialog from the ‘Share’ button in the top right corner of the affected page. Review the settings and either open the page for all users, or add eSign Document Mgmt user as an editor on the page.
Unrestricted Page - Open for View and Edit to users within the Space. This is the default mode for new pages and will not interfere with Document Management.
Restricted Page - Access limited to only specified users in the space. Add eSign Document Mgmt user to the list of allowed editors if a restricted page is necessary.
Contact eSign Support if this does not resolve the issue.